Claytools v4 New Features and Enhancements

The following is a summary of new features and enhancements in Claytools v4. For a more
comprehensive look at the new features and enhancements in the v4 release see the online Help topic
titled “What’s New?” You can access the help from within the Claytools application by pressing F1. Or
from the Start Menu group.

APPLICATION WINDOW

Enhancements:

Memory Meter

The memory meter, located in the bottom right corner of the Claytools application window has
been enhanced with colored memory zone indicators. To the left of the numerical Memory
Usage - which represents the total memory usage of the Claytools application and other
applications running on your system - you will see either a yellow or red memory zone indicator.
If the memory zone indicator is red your system is running low on memory.

CONSTRUCT CLAY
New Features:

Curve Spheres to Clay

The Curve Spheres to Clay tool has been added to the Construct Clay palette. Using this tool you
can edit curve spheres and/or convert curve spheres into clay. To create curve spheres either turn
on the spheres button on the Draw Curve dynabar when drawing a curve, or select a curve and
set the dynabar option "Spheres" to "On" using this tool.

Pipe

The Pipe tool has been added to the Construct Clay palette. You can use the Pipe to easily add or
remove clay using a curve.

Enhancements:
Mirror Clay

A new option has been added to the Mirror Clay dynabar - Mirror Entire Piece. The new option,
combined with the existing Create in New Piece controls the three mirror modes.

If Mirror Entire Piece is off and Create in New Piece is off, the clay on the back of the mirror plane
is removed and the clay in front of the plane is mirrored into the original piece.



If Mirror Entire Piece is on and Create in New Piece is off, the entire piece is mirrored about the
mirror plane in place (no new piece). Note that the clay in front of the plane goes to the back and
the clay in back goes to the front.

If Mirror Entire Piece is on and Create in New Piece is on, it works like above but a copy is
mirrored leaving the original in place.

Pattern Piece

The Pattern Piece tool has been enhanced. The dynabar option, Snap Origin to Endpoint is no
longer selected by default and it now has a submenu that works in conjunction with the Rotation
Control options. The submenu displays different options for Rotation Control selection. Three
options that have been added to this submenu that are always present are Auto Snap Origin for
Curve, Auto Snap Origin for Sketch and Clear Snap.

Wire Cut Clay

The Wire Cut Clay tool has been enhanced to include a Flip check box on the dynabar that
provides the ability to control the direction of the plane offset.

CURVES
Enhancements:

Draw Curve

The Draw Curve dynabar has been enhanced with new modes and a new option. To draw curves
you must select one of the Draw Curve modes:

e C(Create Edit Point Curve
e C(Create Traced Curve
e Replace Curve Segment

Another new option on the dynabar is Curve Spheres. When selected, curve spheres will be
created around the curve. Once drawn, you can use the new tool Curve Spheres to Clay to
convert the spheres to clay. Also, because these spheres are created from curves, you can use
the Mirror Curve tool to create multiple curve spheres.



Fit Curve

The Fit Curve dynabar and advanced options were enhanced. The option Use Global Settings
was renamed Use Settings and was moved from the dynabar to the advanced options along with
the Best fit resolution option.

Projecting a Sketch Curve

The Projecting a Sketch Curve dynabar has been enhanced. The Advanced options have been
removed and replaced with a Tolerance input which defines the control point spacing and
preserves the 2d (sketch) curve profile as it is projected to the target object.

DETAIL CLAY
Enhancements:

Creating a Ridge

The Creating a Ridge tool has been enhanced with a new dynabar option, Join Multiples. With this
check box selected multiple curve selections with shared endpoints will be joined together to
create a ridge. When deselected, separate ridges will be created for each curve.

Emboss with Image

The Emboss with Image tool has been enhanced with new additions to the Image Properties
dialog. New to Image Properties in v4 is the Image Width and Image Height. These fields display
the width and height of the original image in pixels. The option Lock Aspect Ratio has been
renamed Lock Current Aspect Ratio and the option Actual Size has been renamed Reset Aspect -
this option will reset the current while recomputing with the specified Resolution.

GENERAL OPTIONS
New Features:

Memory Options
The Tools Menu>Options>General section has a new page of options specifically for Memory.
Spaceball Options

The Tools Menu>Options>General section has a new page of options specifically for the Spaceball
device. The Spaceball device provides the ability to manipulate the controller's pressure-sensitive
handle to pan, zoom and rotate 3D imagery simultaneously, without stopping to change
directions using keyboard shortcuts or the software interface.



Enhancements:
Curve Options

The Tools Menu>Options>General>Curves dialog has a new option, Preview Draw Curve fit
point. This option, selected by default, will enable a preview of the curve point when drawing a
curve that will be fit to a clay or mesh. A shadow point will appear on the surface identifying
where the fit point will be placed when the curve is not in contact with the surface.

Features Options

The Tools Menu>Options>General>Features dialog has a new option. The option File Import
saves/restores prior view provides the capability to return to the view in effect before you
imported a file.

Object List Options

The Tools Menu>Options>General section has a new page of options specifically for the Object
List. In previous versions some of these options were located on different dialog pages, such as
Force Unique Object List Names. New options have also been added to this added, such as Show
Toolbar, and Override Folder Visibility (for Pieces). Also added to the Object List options is a
check box Remember Object Type filter states which, when selected, will recall the state of your
Object List Filters (from the Object List Toolbar) between Claytools sessions.

With the option Override Folder Visibility (for Pieces) selected pieces in the Object List will
remain visible when the Flatten Folders option has been enabled on the Object List toolbar.

The Obiject List has also been enhanced to improve the renaming of objects. With the option
Rename objects with double click selected, you can double click an object name in the Object
List to rename that Object. You cannot double click to rename a folder or sketch elements in the
Object List.

OBIJECT LIST
New Features:

Clay Utilities

The Obiject List Context Menu has a new sub-menu, Clay Utilities. The commands found on this
sub-menu include: Copy to Mesh, Fill Voids, Create Offset Piece, Add to Mask and Add to Buck.

Export Planes as .CLY Files

You can now export Planes as .cly files through the Object List Export Model dialog.



Mesh Utilities

The Object List Context Menu has a new sub-menu, Mesh Utilities. The commands found on this
sub-menu include: Copy to Clay, Divide, and Reverse.

Enhancements:

Duplicate

The Duplicate option, found on the Object List Context Menu has been enhanced to provide the
capability to duplicate a selected Folder and its contents as well as selected Planes in the Object
List.

Hide Associated Objects

The eye icon indicates if the object is visible. The Object List has been enhanced so that you can
also hide the associated objects of a piece, for example a curve. Pressing the Alt key and clicking
the eye icon will hide or show the associated objects.

Object List Search Function

The Obiject List Search Function was enhanced with new search options. The options, Find &
Select All and Find & Select Cumulatively were replaced with Select One, Add to Selection, and
Select All Instances. These new options provide the ability to highlight search results one object at
a time, to keep search results highlighted as you scroll through the Object List and to highlight all
search results in the Object List.

Also added to the Search Function is the option, Loop Back to Start/End. Select this option to
automatically continue searching the Object List when the search has reached the top or bottom
of the Object List.

Object List Toolbar

The Obiject List was updated with a toolbar. The Toolbar runs across the bottom of the Object List
and has eight icons. The icons provide the ability to sort the Object List alphabetically, to
hide/show folders, planes, curves, and hidden objects, as well as open the Object List Search
Function.

Override Folder Visibility (for Pieces)

The option, Override Folder Visibility (for Pieces) was added to the new Object List Options dialog
through the Tool menu. You can use this option so that pieces in the Object List will remain visible
in the Object List when the Flatten Folders option has been enabled on the Object List toolbar.



Renaming in the Object List

The Object List has been enhanced to improve the renaming of objects. In previous versions of
Claytools, you had to rename an object using the Object List Context Menu. While that option still
exists, with the option Rename objects with double click selected in the
Tools>Options>General>0bject List selected, you can double click an object name in the Object
List to rename that Object. You cannot double click to rename a folder or sketch elements in the
Object List.

See Through On/Off

The See Through Objects function has been enhanced to provide the capability to set the see-
through status of multiple objects at the same time. With multiple objects selected in the Object
List you can access this option by right-clicking one of the selected objects to view the Object List
Context Menu.

Show Children/Hide Children

The Show Children/Hide Children options found on the Object List Context Menu for planes are
enhancements that provide the capability to show or hide all sketch elements from a selected
plane in the Object List and workspace.

PAINT

New Features:
Airbrush

The Airbrush tool has been added to the new Paint palette. Using this tool you can color a model
with an airbrush.

Paint

The Paint tool has been added to the new Paint palette. Using this tool you can color a model with
a paintbrush.

Project Image

The Project Image tool has been added to the new Paint palette. Using the Project Image tool you
can project an image to the model from a plane.

Wrap Image

The Wrap Image tool has been added to the new Paint palette. Using the Wrap Image tool you
can apply an image (.bmp, .jpg or .psd) to an area of the model defined by a four-sided curve loop.



POSITIONING

Enhancements:
Reposition Piece

The Reposition Piece tool has been enhanced. If you are manipulating heavy clay pieces, the
shading, set in View Menu>Shading Clay will automatically default to Always Sparse Shade to
improve the speed of your manipulation. However, if you have already set the Shade Clay settings
to Always Full Shade the settings will not be altered. With Always Full Shade selected
manipulations may be made more slowly and appear as choppy movements. A piece will not
default to Always Sparse Shade if you are using Precise Movement.

SCULPT CLAY

New Features:
Carve with Corn Dog

The Carve with Corn Dog tool has been added to the Sculpt Clay palette. Use this tool to carve
into clay with a corn dog-shaped tool head.

Carve with Cube

The Carve with Cube tool has been added to the Sculpt Clay palette. Use this tool to carve into
clay with a cube-shaped tool head.

Carve with Scraper

The Carve with Scraper tool has been added to the Sculpt Clay palette. Use this tool to carve with
a scraper-shaped tool head.

Hot Wax

The Hot Wax tool has been added to the Sculpt Clay palette. Use this tool to interactively melt the
edges of the clay with a ball-shaped tool by adding or removing clay. Hot Wax has very unique
dynabar options for smoothing clay - Melt, Smooth, Add and Remove. The dynabar also includes
the Mask Transition drop-down menu. On the drop-down menu you will find the following
transition options, None, Blended, and Sharp which control how/if the mask volume will be
smoothed.

Enhancements:
Smooth

The Smooth tool has been. New dynabar options have also been added to the Smooth Tool that
provides the capability to select a Smoothing mode. The available modes are Outside Smooth and



Inside Smooth. The Outside Smooth option will smooth the clay with an area of influence outside
the tool sphere while the Inside Smooth option uses the area of influence within the tool sphere.

The Smooth tool has also been enhanced to improve smoothing when there is a mask involved.
The Blend with Mask check box has been replaced with a Mask Transition drop-down menu. On
the drop-down menu you will find the following transition options, None, Blended, and Sharp
which control how/if the mask volume will be smoothed.

Smooth Area

The Smooth Area tool has been enhanced to improve smoothing when there is a mask involved.
The Blend with Mask check box has been replaced with a Mask Transition drop-down menu. On
the drop-down menu you will find the following transition options, None, Blended, and Sharp
which control how/if the mask volume will be smoothed.

SELECT/MOVE CLAY
Enhancements:

Mask

The Mask tool has been enhanced. The Add to Selection icon has been removed from the
dynabar. In Claytools v4, Mask is set to Add to Selection by default and the Remove from
Selection icon has been changed on the dynabar.

Select with Ball

The Select with Ball tool has been enhanced. The Add to Selection icon has been removed from
the dynabar. In Claytools v4, Select with Ball is set to Add to Selection by default and the Remove
from Selection icon has been changed on the dynabar.

Select with Lump

The Select with Lump tool has been enhanced. The Add to Selection icon has been removed from
the dynabar. In Claytools v4, Select with Lump is set to Add to Selection by default and the
Remove from Selection icon has been changed on the dynabar.

Select with Profile

The Select with Profile tool has been enhanced. The Add to Selection icon has been removed from
the dynabar. In Claytools v4, Select with Profile is set to Add to Selection by default and the
Remove from Selection icon has been changed on the dynabar.



Separate Tool

The Separate Tool has been enhanced with the capability to separate mesh objects. Mesh objects
can be separated with a plane. You cannot multi-separate a mesh object or separate a mesh with
a curve.

SKETCH

Enhancements:
Control Point Curve

The Control Point Curve tool has been enhanced to remove the editing options Preserve Detail
and Uniform Spacing. These options are now only available when you Select a Sketch Object to
edit.

Freehand Curve

The Freehand Curve tool has been enhanced to remove the editing options Preserve Detail and
Uniform Spacing. These options are now only available when you Select a Sketch Object to edit.

TOOLS MENU
New Features:

Repair Curves

A new option, Repair Curves, has been added to the Tools menu. This command detects zero
length curves, duplicate curves, similar curves and duplicate end points. The command allows you
to delete the offending curves and merge the end points. In the case of duplicate and similar
curves there is an option to hide the offending curves as well as delete them.

VIEW MENU

New Features:
Hide/Show Mesh Pieces

A new toggle option has been added to the View menu, Show Meshes. Click to toggle the display
of mesh pieces on and off. When selected, only the active mesh piece in the Object List will be
shown in the workspace. When deselected, all entities will be shown in the workspace.



VIEW OPTIONS

Enhancements:
Colors Options

The Tools Menu>Options>View>Colors dialog has a new option, Use Background Image. Selecting
the checkbox provides the ability to browse for and select a specific image to use for workspace
background.

Setup Options

The Tools>Options>View>Setup dialog has a new section for View Rotation Center. There are
three check boxes: Bounding box center of all visible objects, Active piece origin, and Global
Origin. Select one of these options to define the center for an objects rotation. The Setup dialog
has also renamed the Parting Line Draft Angle input. This input is now named, Angle for Draft
Colors.

Sketch Options

The Tools>Options>General>Sketch dialog has a new section for shrinking sketch planes using the
hot key Alt+M. In the sketch options you can choose to shrink the plane using the sketch object as
the center or the center of the current (active) plane as the center.



